jump to navigation

Actualizando/Instalando Beryl desde svn y el efecto 3d World noviembre 12, 2006

Posted by Benux in Distribuciones, Escritorios, Eye Candy, Linux, Otros, Software, ubuntu.
trackback

La información de este post se encuentra en Benuxideas mi nuevo blog, en donde se tratara de que este lo mas actualizado posible, la dirección del post es la siguiente: Actualizando/Instalando Beryl desde svn y el efecto 3d World

NOTA: Ahora tambien en mas facil obtener el efecto 3d World, ya se encuentra en los repositorios de treviño, basicamente es el svn pero empaquetado en .deb, si gustan la instalacion por repositorios, aqui dejo el link:

Instalación/Actualización desde repositorios de Beryl

Y para los que gusten el svn pues sigan con el, ya que aun tiene una ventaja, que cuando aparezca un nuevo plugin apantallante tengan por seguro de que seran de los primeros en tenerlo funcionando.

Sigamos entonces con la instalación via svn, esta instalacion tambien sirve para usuarios con AMD.

instalemos lo siguiente desde la terminal:

sudo apt-get install fakeroot automake1.9 x11proto-gl-dev subversion libtool librsvg2-dev libglitz-glx1-dev libglitz1-dev libneon25-dev libapr0-dev libsvn0-dev intltool libxdamage-dev libxfixes-dev xlibs-dev icecc iceconf libxcomposite1 libxcomposite-dev libstartup-notification0-dev libwnck-dev fort77 gawk g77 build-essential cvs libpango1.0-dev libgtk2.0-dev libgconf2-dev libglitz-glx-dev librsvg2-dev checkinstall libglade2-dev libmetacity-dev libgnome-window-settings-dev libgnome-desktop-dev

Sigan las instrucciones del siguiente tutorial en caso de que no hayan instalado beryl anteriormente, claro que tambien es recomendable que lo vean como referencia los que ya lo han instalado anteriormente.

Como Instalar XGL/BERYL en Gnome/Kde Nvidia y ATI Dapper/Edgy

para los que quieren actualizar es recomendable que desinstalen primero los paquetes de beryl que ya tenian ya que no van a servir de nada.

Para Instalar beryl desde svn es muy sencillo y estaremos seguros de que nuestro beryl estara actualizado al maximo, claro que esto hay que hacerlo cada que queramos actualizar.

despues de instalar las librerias y programas anteriormente mencionados bajamos nuestro beryl con el siguiente codigo desde la terminal:

svn co svn://svn.beryl-project.org/beryl/trunk

cuando termine de bajar solo entramos a la carpeta desde la terminal asi (nota: cambia la parte de usuario por el tuyo):

cd /home/usuario/trunk

ya que estemos dentro ejecutamos lo siguiente:

./makeall

listo ahora solo esperemos a que acabe de instalar beryl.

Nota: En caso de que no nos instale emerald no se preocupen lo instalaremos desde su carpeta de la siguiente forma:

entramos a la carpeta de emerald asi:

cd /home/usuario/trunk/emerald

y ejecutamos lo siguiente linea por linea

./autogen.sh

./configure

make

sudo make install

listo ahora instalemos los temas, entramos a la carpeta de emerald-themes asi:

cd /home/usuario/trunk/emerald-themes

ya dentro ejecutamos nuevamente lo siguiente:

./autogen.sh

./configure

make

sudo make install

3D WORLD

Ahora instalemos nuestro 3d world no olviden que tienen que instalar las librerias y programas que se encuentran al principio de este post aqui esta un ejemplo de que es este plugin de Beryl:

estas son unas imagenes de mi escritorio con 3d world:

den click en la imagen que deseen ver.

escritorio.jpg

escritorio2.jpg

esta es otra imagen de mi beryl con una combinación de los plugins 3d world e input enable zoom.

el input enable zoom hace que nuestro cubo se convierta en una simple hoja al tratar de hacer

Comentarios»

1. Como Instalar XGL/BERYL en Gnome/Kde Nvidia y ATI Dapper/Edgy « Benux Edgy - noviembre 12, 2006

[…] BERYL ACTUALIZADO DESDE SVN […]

2. Tener tu BERYL actualizado desde repositorios. « Benux Edgy - noviembre 12, 2006

[…] Instalando/Actualizando beryl desde svn y el efecto 3d world […]

3. Alvarock - noviembre 13, 2006

Hola Sabes que estaba viendo lo del plugin 3d world y es realmente “nice” pero siguiendo tu guia tengo un pekeño problema no se si me pudieras ayudar…

cuando hago el “make”, me lanza lo siguiente y no consigo captar el error, =(

-e compiling : 3d.c -> build/lib3d.loPackage x11 was not found in the pkg-config search path.
Perhaps you should add the directory containing `x11.pc’
to the PKG_CONFIG_PATH environment variable
No package ‘x11′ found
Package beryl was not found in the pkg-config search path.
Perhaps you should add the directory containing `beryl.pc’
to the PKG_CONFIG_PATH environment variable
No package ‘beryl’ found
/bin/sh: libtool: not found
make: *** [build/lib3d.lo] Error 127

de cualquier forma gracias

4. Fred.cpp - noviembre 13, 2006

Excelente, se me hace que ya daré el brinco a la versión svn, solo por curiosidad.
Una pregunta, como sientes el rendimiento?

5. Benux - noviembre 13, 2006

pues esta, me permito decirlo poca madre todo corre de maravilla y lo mejor del svn es que estan todos los plugins incluso el de capturar video, voy a poner un post de como configurar este plugin pero hasta que deje de tener problemas de convertir el video .seom a uno como avi, mpeg,etc. pero si recomiendo el svn definitivamente.

6. Benux - noviembre 13, 2006

Reply
…Alvarock…Hola Sabes que estaba viendo lo del plugin 3d world y es realmente “nice” pero siguiendo tu guia tengo un pekeño problema no se si me pudieras ayuda…

pues parece ser que te falta instalar todas las librerias y programas mencionado al principio del post, tambien tengo duda de esta linea “No package ‘beryl’ found” esto me lleva a la siguiente pregunta ¿tienes beryl instalado? si no lo tienes pues lo instalas.

bueno espero que esto te haya servido, si no resuelve el problema hazmelo saber y pues buscare mas a detalle el problema.

7. Javier Aroche - noviembre 13, 2006

lo bueno de compilar desde SVN es que para actualizarte no hay que bajar mucho, a cambio de usar el CPU unos 5-10 minutos compilando. Llevo compilando desde la 0.1.1 y no he tenido mayores problemas.

8. Daniel - noviembre 14, 2006

Hola, he seguido la guía para instalar 3d world pero me da el siguiente error al ejecutar make:

-e compiling : 3d.c -> build/lib3d.loPackage beryl was not found in the pkg-config search path.
Perhaps you should add the directory containing `beryl.pc’
to the PKG_CONFIG_PATH environment variable
No package ‘beryl’ found
3d.c:45:19: error: beryl.h: No such file or directory
(…y sigue…)

he leido en un comentario más arriba que a alguien le pasa algo similar. Sin embargo, yo sí estoy seguro de tener beryl instalado (lo estoy ejecutando ahora mismo y funciona perfectamente).

Así, pues, alguna idea de por qué motivo tengo este error? Por cierto, ya ejecuté la primera linea del tutorial (sudo apt-get install fakeroot automa…)

Gracias por adelantado🙂

9. Benux - noviembre 14, 2006

mmm parece que el problema esta solo cuando no se instala beryl desde svn y se saltan la hasta 3d world.
con esto quiero entender que la version anterior de beryl no soporta el 3d world asi que les recomiendo que sigan el tutorial para instalar beryl desde svn ya que esto les instala el beryl 0.1.3.
Espero que esto solucione el problema si no haganmelo saber de favor.

10. Alvarock - noviembre 14, 2006

ok, pienso que puede ser eso, aunk yo tengo instalado el beryl 0.1.3 =D

asi que creo q tendre q esperar a q se haga “oficial” el plugin
=(

11. Alvarock - noviembre 14, 2006

~$ beryl –version
beryl-core 0.1.3

😉

12. Rafa - noviembre 15, 2006

como puedo reemplazar este comando para kde svn co svn://svn.beryl-project.org/beryl/trunk.

13. Rafa - noviembre 15, 2006
14. Benux - noviembre 15, 2006

segun yo es el mismo comando que es lo que pasa o que no sale?
tienes instalado el subversion?

15. psylosibinetic - noviembre 15, 2006

¬¬ my beryl no se a actualizado a la vercion 1.3 no sale de la 1.1 shale y ya e echo los pasos que bienen ariba a y otra pregunta ya tengo descargado el pluguin 3d qeu esta en
/home/usuario/beryl-3d-plugin en una de las instruccioines dice que le de el comando de

cd /home/usuario/beryl-3d-plugin y me sale que no lo encontro para que es eso comando de cd ???????? cuando le quito lo de cd se va a la carpedeta de pluguin ¬¬ soy novato en linux aun aganme el paro porfa

16. Rafa - noviembre 15, 2006

instale todo me sale el efecto 3d en gestor de preferencias beryl lo activo pero aun asi no pasa nada, alguien sabe que puede ser??????

17. Rafa - noviembre 15, 2006

recien note que la version sigue siendo la 0.1.2 ¬¬ que podra ser hice todos los pasos como deberia ser

18. Benux - noviembre 15, 2006

respuesta a psylosibinetic:
pues para lo de la version, pues en el gestor de paquetes te van a aparecer los paquetes que habias instalado de beryl, cuando actualizas el beryl por svn no te sirven de nada ya los paquetes del gestor de paquetes synaptic.
lo que te puedo recomendar es que desinstales dichos paquetes e instales de nuevo desde svn.

y lo de cd /home/usuario/beryl-3d-plugin es para ingresar a la direccion de tu carpeta desde la terminal cambia la parte de usuario por tu nombre de usuario.

19. Benux - noviembre 15, 2006

respuesta a Rafa:
ya reiniciaste tu equipo?
porque cuando yo igual instale el 3d world no funcionaba aunque lo activara hasta que reinicie mi compu y funcionaba todo perfectamente, o tambien puede que no notes ningun cambio es porque tal vez tengas la parte de space between windows en 0 esto se encuentra en la pestaña de numeric values.
si esto no corrige el problema hazmelo saber de favor.

20. Rafa - noviembre 15, 2006

benux cuando parte beryl me sale esa pantalla gelatinosa 0.1.2 deberia salir 0.1.3 o aun no agregan eso porque al menos el emeral esta en la version 0.1.3.

saludos

21. Benux - noviembre 15, 2006

bueno en eso si tienes razon el splash es 0.1.2 pero ese siempre lo modifican hasta la siguiente version como que van atrasados en eso, porque cuando tenia la 0.1.2 seguia con el splash de 0.1.1.
y pues tambien el beryl settings manager esta en 0.1.3

22. Rafa - noviembre 15, 2006

ah ok pero entonces, si ya tengo instalado el plugin 3d porque al menos lo puedo seleccionar desde las settings de beryl, que puede pasar que no veo el efecto 3d, modifique los valores numericos dandole el maximo de separacion pero aun así nada, hay alguna combinacion de teclas o algo.

Saludos y gracias por tu ayuda

23. Benux - noviembre 15, 2006

ya reiniciaste es que esa es mi duda?
y pues no se ponle un valor de 0,070 asi lo tengo yo y se ve bien aunque esto es como tu gustes.

24. Benux - noviembre 15, 2006

y funciona solo al mover el cubo con el mouse.

25. Rafa - noviembre 15, 2006

mira ahi unos screen shots haber si me puedes dar una mano, alomejor solo es cosa de configuración o que se yo, porque no me funciona nada😦.

26. Rafa - noviembre 15, 2006

y si he reiniciado el pc completo y todo pero nada

27. Benux - noviembre 15, 2006

chispas no se que pueda ser realmente lo que este fallando haber trata de instalarlo con el makeall de la carpeta
metete a la carpeta de beryl-3d-plugin

cd /home/usuario/beryl-3d-plugin

y dale:

sudo ./makeall

28. Benux - noviembre 15, 2006

tal vez este era el problema lo que pasa es que no habia checado el contenido del makeall y venian mas instrucciones de make si si es este el problema pues modifico rapidisimo el post porque es un grave error de mi parte.

29. Rafa - noviembre 15, 2006

ahora me sale esto

rfarias@rfarias-desktop:~/beryl-3d-plugin$ sudo ./makeall
sudo: ./makeall: command not found

30. Benux - noviembre 15, 2006

te faltan instalar las librerias que se encuentran hasta arriba de este post

31. Rafa - noviembre 15, 2006

trate con kdesu me da permission denied

32. Rafa - noviembre 15, 2006

a vale

33. Rafa - noviembre 15, 2006

sigo con el mismo error de arriba y se supone que instalo las librerias

34. Benux - noviembre 15, 2006

si instalaste todo lo de arriba ya debe de funcionar haber trata poniendo solo ./makeall sin el sudo

y si no ejecuta todo esto linea por linea:

make
make -f MakefileRotate
make -f MakefileZoom
sudo make install
sudo make -f MakefileRotate install
sudo make -f MakefileZoom install

todo lo anterior es lo que viene en el archivo makeall.

35. psylosibinetic - noviembre 15, 2006

shale como que estoy muy menso o no se que salga mal el chiste es que el comando cd ¬¬ no me charcha ya le cambie

cd /home/usuario/beryl-3d-plugin por
………roberto……………
y me sigue saliendo que no se encuentra y cuando le
pongo solo

/home/roberto/beryl-3d-plugin

se transporta a la carpeta
que pedo todos los pasos ya los tengo solo me falta eso

(T_T)
com hay que ago ya me fige en el nombre de la carpeta el pedo es cuando le pongo cd cuando no se lo pong se ba a la carpeta que ????? ago (T_T)

36. Rafa - noviembre 15, 2006

ahi si gracias por todo!!!!!! ujujujujuj

37. Benux - noviembre 15, 2006

lo estas haciendo desde la terminal? si quieres subo una imagen para que veas como sale

38. Benux - noviembre 15, 2006

perfecto que bueno que ya salio lo del 3d world.

39. Saul Romero - noviembre 15, 2006

Hey que tal, oye intente todo lo que dices, pero en el primer makeall me arroja este error
autoreconf2.50: Entering directory `.’
autoreconf2.50: configure.ac: not using Gettext
autoreconf2.50: running: aclocal
aclocal:configure.ac:22: warning: macro `AM_GLIB_GNU_GETTEXT’ not found in library
autoreconf2.50: configure.ac: tracing
autoreconf2.50: running: libtoolize –copy
aclocal:configure.ac:22: warning: macro `AM_GLIB_GNU_GETTEXT’ not found in library
autoreconf2.50: running: /usr/bin/autoconf
configure.ac:22: error: possibly undefined macro: AM_GLIB_GNU_GETTEXT
If this token and others are legitimate, please use m4_pattern_allow.
See the Autoconf documentation.
autoreconf2.50: /usr/bin/autoconf failed with exit status: 1
BUILD FAILED for beryl-core
—–

ya instale todo lo que tiene que ver con auto y no funciona, espero me ayudes, gracias

40. Benux - noviembre 15, 2006

si instalaste todo lo que se encuentra hasta arriba de este post?
que version de automake tienes?

41. Saul Romero - noviembre 16, 2006

Que hay , soy yo de nuevo, ya me brinque ese error, haciendo antes

sudo apt-get build-dep compiz

grax

42. Saul Romero - noviembre 16, 2006

Una vez mas

Ahora el problema es con una libreria creo , la trato de instalar con apt o con synaptic y no la encuentra, sabes de donde la puedo conseguir o un repositorio? graX

checking for BERYL… configure: error: Package requirements (libpng xcomposite >= 0.3 xfixes xdamage xrandr ice sm xinerama libstartup-notification-1.0 >= 0.7) were not met:

Requested ‘xcomposite >= 0.3’ but version of Xcomposite is 0.2.2.2

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables BERYL_CFLAGS
and BERYL_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

43. Benux - noviembre 16, 2006

aqui dejo el link de este post:
https://benux.wordpress.com/2006/11/01/ubuntu-edgy-codecs-multimedia-aceleracion-grafica-beryl-kde-gnome/
aqui coloque unos repositorios, con estos no tuve ningun problema para la instalación de beryl.

44. Benux - noviembre 16, 2006

esos son para edgy y si tienes dapper aqui dejo el sources.list que usaba yo.
https://benux.wordpress.com/sourceslist/
tampoco tuve problemas para beryl.

45. Artanix - noviembre 16, 2006

tuve algunos problemas al ejecutar “sudo ./makeall” qué puede ser esto??:

cube.c:1282: error: request for member ‘f’ in something not a structure or union
cube.c:1282: warning: statement with no effect
cube.c:1283: error: request for member ‘rest’ in something not a structure or union
cube.c:1283: error: request for member ‘f’ in something not a structure or union
cube.c:1283: error: request for member ‘min’ in something not a structure or union
cube.c:1283: warning: statement with no effect
cube.c:1284: error: request for member ‘rest’ in something not a structure or union
cube.c:1284: error: request for member ‘f’ in something not a structure or union
cube.c:1284: error: request for member ‘max’ in something not a structure or union
cube.c:1284: warning: statement with no effect
cube.c:1285: error: request for member ‘rest’ in something not a structure or union
cube.c:1285: error: request for member ‘f’ in something not a structure or union
cube.c:1285: error: request for member ‘precision’ in something not a structure or union
cube.c:1285: warning: statement with no effect
cube.c:1287: error: ‘CubeScreen’ has no member named ‘opt’
cube.c:1287: warning: statement with no effect
cube.c:1288: error: request for member ‘name’ in something not a structure or union
cube.c:1288: warning: statement with no effect
cube.c:1289: error: request for member ‘shortDesc’ in something not a structure or union
cube.c:1289: warning: statement with no effect
cube.c:1290: error: request for member ‘longDesc’ in something not a structure or union
cube.c:1290: warning: statement with no effect
cube.c:1291: error: request for member ‘type’ in something not a structure or union
cube.c:1291: warning: statement with no effect
cube.c:1292: error: request for member ‘value’ in something not a structure or union
cube.c:1292: error: request for member ‘f’ in something not a structure or union
cube.c:1292: warning: statement with no effect
cube.c:1293: error: request for member ‘rest’ in something not a structure or union
cube.c:1293: error: request for member ‘f’ in something not a structure or union
cube.c:1293: error: request for member ‘min’ in something not a structure or union
cube.c:1293: warning: statement with no effect
cube.c:1294: error: request for member ‘rest’ in something not a structure or union
cube.c:1294: error: request for member ‘f’ in something not a structure or union
cube.c:1294: error: request for member ‘max’ in something not a structure or union
cube.c:1294: warning: statement with no effect
cube.c:1295: error: request for member ‘rest’ in something not a structure or union
cube.c:1295: error: request for member ‘f’ in something not a structure or union
cube.c:1295: error: request for member ‘precision’ in something not a structure or union
cube.c:1295: warning: statement with no effect
cube.c:1297: error: ‘CubeScreen’ has no member named ‘opt’
cube.c:1297: warning: statement with no effect
cube.c:1298: error: request for member ‘name’ in something not a structure or union
cube.c:1298: warning: statement with no effect
cube.c:1299: error: request for member ‘shortDesc’ in something not a structure or union
cube.c:1299: warning: statement with no effect
cube.c:1300: error: request for member ‘longDesc’ in something not a structure or union
cube.c:1301: warning: statement with no effect
cube.c:1302: error: request for member ‘type’ in something not a structure or union
cube.c:1302: warning: statement with no effect
cube.c:1303: error: request for member ‘value’ in something not a structure or union
cube.c:1303: error: request for member ‘b’ in something not a structure or union
cube.c:1303: error: ‘TRUE’ undeclared (first use in this function)
cube.c:1303: warning: statement with no effect
cube.c:1305: error: ‘CubeScreen’ has no member named ‘opt’
cube.c:1305: warning: statement with no effect
cube.c:1306: error: request for member ‘name’ in something not a structure or union
cube.c:1306: warning: statement with no effect
cube.c:1307: error: request for member ‘shortDesc’ in something not a structure or union
cube.c:1307: warning: statement with no effect
cube.c:1308: error: request for member ‘longDesc’ in something not a structure or union
cube.c:1308: warning: statement with no effect
cube.c:1309: error: request for member ‘type’ in something not a structure or union
cube.c:1309: warning: statement with no effect
cube.c:1310: error: request for member ‘value’ in something not a structure or union
cube.c:1310: error: request for member ‘b’ in something not a structure or union
cube.c:1310: warning: statement with no effect
cube.c:1312: error: ‘CubeScreen’ has no member named ‘opt’
cube.c:1312: warning: statement with no effect
cube.c:1313: error: request for member ‘name’ in something not a structure or union
cube.c:1313: warning: statement with no effect
cube.c:1314: error: request for member ‘shortDesc’ in something not a structure or union
cube.c:1314: warning: statement with no effect
cube.c:1315: error: request for member ‘longDesc’ in something not a structure or union
cube.c:1315: warning: statement with no effect
cube.c:1316: error: request for member ‘type’ in something not a structure or union
cube.c:1316: warning: statement with no effect
cube.c:1317: error: request for member ‘value’ in something not a structure or union
cube.c:1317: error: request for member ‘b’ in something not a structure or union
cube.c:1317: warning: statement with no effect
cube.c:1319: error: ‘CubeScreen’ has no member named ‘opt’
cube.c:1319: warning: statement with no effect
cube.c:1320: error: request for member ‘name’ in something not a structure or union
cube.c:1320: warning: statement with no effect
cube.c:1321: error: request for member ‘shortDesc’ in something not a structure or union
cube.c:1321: warning: statement with no effect
cube.c:1322: error: request for member ‘longDesc’ in something not a structure or union
cube.c:1322: warning: statement with no effect
cube.c:1323: error: request for member ‘type’ in something not a structure or union
cube.c:1323: warning: statement with no effect
cube.c:1324: error: request for member ‘value’ in something not a structure or union
cube.c:1324: error: request for member ‘b’ in something not a structure or union
cube.c:1324: warning: statement with no effect
cube.c:1326: error: ‘CubeScreen’ has no member named ‘opt’
cube.c:1326: warning: statement with no effect
cube.c:1327: error: request for member ‘name’ in something not a structure or union
cube.c:1327: warning: statement with no effect
cube.c:1328: error: request for member ‘shortDesc’ in something not a structure or union
cube.c:1328: warning: statement with no effect
cube.c:1329: error: request for member ‘longDesc’ in something not a structure or union
cube.c:1330: warning: statement with no effect
cube.c:1331: error: request for member ‘type’ in something not a structure or union
cube.c:1331: warning: statement with no effect
cube.c:1332: error: request for member ‘value’ in something not a structure or union
cube.c:1332: error: request for member ‘b’ in something not a structure or union
cube.c:1332: warning: statement with no effect
cube.c: At top level:
cube.c:1335: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
cube.c: In function ‘adjustVelocity’:
cube.c:1359: error: ‘CubeScreen’ has no member named ‘unfolded’
cube.c:1360: error: ‘CubeScreen’ has no member named ‘unfold’
cube.c:1360: error: invalid operands to binary –
cube.c:1360: error: incompatible types in assignment
cube.c:1360: warning: statement with no effect
cube.c:1362: error: ‘CubeScreen’ has no member named ‘unfold’
cube.c:1362: error: invalid operands to binary –
cube.c:1362: error: incompatible types in assignment
cube.c:1362: warning: statement with no effect
cube.c:1364: error: ‘CubeScreen’ has no member named ‘acceleration’
cube.c:1364: error: invalid operands to binary *
cube.c:1364: error: incompatible types in assignment
cube.c:1364: warning: statement with no effect
cube.c:1371: error: ‘CubeScreen’ has no member named ‘unfoldVelocity’
cube.c:1371: error: ‘CubeScreen’ has no member named ‘unfoldVelocity’
cube.c:1371: error: invalid operands to binary *
cube.c:1371: error: invalid operands to binary +
cube.c:1372: error: invalid operands to binary /
cube.c:1372: warning: statement with no effect
cube.c:1374: error: ‘CubeScreen’ has no member named ‘unfoldVelocity’
cube.c:1374: error: incompatible type for argument 1 of ‘fabs’
cube.c: At top level:
cube.c:1378: error: expected ‘)’ before ‘*’ token
cube.c:1423: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘cubePaintScreen’
cube.c:1484: error: expected ‘)’ before ‘*’ token
cube.c:1497: error: expected ‘)’ before ‘*’ token
cube.c:1900: error: expected ‘)’ before ‘*’ token
cube.c:1912: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘cubeUnfold’
cube.c:1952: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘cubeFold’
cube.c:1981: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘cubeNextImage’
cube.c:2013: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘cubePrevImage’
cube.c:2048: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘cubeSetGlobalScreenOption’
cube.c:2067: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘cubeSetDisplayOption’
cube.c: In function ‘cubeDisplayInitOptions’:
cube.c:2100: error: ‘CompOption’ undeclared (first use in this function)
cube.c:2100: error: ‘o’ undeclared (first use in this function)
cube.c:2100: error: invalid operands to binary *
cube.c:2100: warning: statement with no effect
cube.c:2102: error: ‘CubeDisplay’ has no member named ‘opt’
cube.c:2102: warning: statement with no effect
cube.c:2103: error: request for member ‘name’ in something not a structure or union
cube.c:2103: warning: statement with no effect
cube.c:2104: error: request for member ‘shortDesc’ in something not a structure or union
cube.c:2104: warning: statement with no effect
cube.c:2105: error: request for member ‘longDesc’ in something not a structure or union
cube.c:2105: warning: statement with no effect
cube.c:2106: error: request for member ‘type’ in something not a structure or union
cube.c:2106: error: ‘CompOptionTypeAction’ undeclared (first use in this function)
cube.c:2106: warning: statement with no effect
cube.c:2107: error: request for member ‘value’ in something not a structure or union
cube.c:2107: error: request for member ‘action’ in something not a structure or union
cube.c:2107: error: request for member ‘initiate’ in something not a structure or union
cube.c:2107: error: ‘cubeUnfold’ undeclared (first use in this function)
cube.c:2107: warning: statement with no effect
cube.c:2108: error: request for member ‘value’ in something not a structure or union
cube.c:2108: error: request for member ‘action’ in something not a structure or union
cube.c:2108: error: request for member ‘terminate’ in something not a structure or union
cube.c:2108: error: ‘cubeFold’ undeclared (first use in this function)
cube.c:2108: warning: statement with no effect
cube.c:2109: error: request for member ‘value’ in something not a structure or union
cube.c:2109: error: request for member ‘action’ in something not a structure or union
cube.c:2109: error: request for member ‘bell’ in something not a structure or union
cube.c:2109: error: ‘FALSE’ undeclared (first use in this function)
cube.c:2109: warning: statement with no effect
cube.c:2110: error: request for member ‘value’ in something not a structure or union
cube.c:2110: error: request for member ‘action’ in something not a structure or union
cube.c:2110: error: request for member ‘edgeMask’ in something not a structure or union
cube.c:2110: warning: statement with no effect
cube.c:2111: error: request for member ‘value’ in something not a structure or union
cube.c:2111: error: request for member ‘action’ in something not a structure or union
cube.c:2111: error: request for member ‘state’ in something not a structure or union
cube.c:2111: error: ‘CompActionStateInitEdge’ undeclared (first use in this function)
cube.c:2111: warning: statement with no effect
cube.c:2112: error: request for member ‘value’ in something not a structure or union
cube.c:2112: error: request for member ‘action’ in something not a structure or union
cube.c:2112: error: request for member ‘state’ in something not a structure or union
cube.c:2112: error: ‘CompActionStateInitKey’ undeclared (first use in this function)
cube.c:2112: warning: statement with no effect
cube.c:2113: error: request for member ‘value’ in something not a structure or union
cube.c:2113: error: request for member ‘action’ in something not a structure or union
cube.c:2113: error: request for member ‘state’ in something not a structure or union
cube.c:2113: error: ‘CompActionStateInitButton’ undeclared (first use in this function)
cube.c:2113: warning: statement with no effect
cube.c:2114: error: request for member ‘value’ in something not a structure or union
cube.c:2114: error: request for member ‘action’ in something not a structure or union
cube.c:2114: error: request for member ‘type’ in something not a structure or union
cube.c:2114: error: ‘CompBindingTypeKey’ undeclared (first use in this function)
cube.c:2114: warning: statement with no effect
cube.c:2115: error: request for member ‘value’ in something not a structure or union
cube.c:2115: error: request for member ‘action’ in something not a structure or union
cube.c:2115: error: request for member ‘key’ in something not a structure or union
cube.c:2115: error: request for member ‘modifiers’ in something not a structure or union
cube.c:2115: error: ‘ControlMask’ undeclared (first use in this function)
cube.c:2115: error: ‘CompAltMask’ undeclared (first use in this function)
cube.c:2115: error: invalid operands to binary |
cube.c:2115: warning: statement with no effect
cube.c:2116: error: request for member ‘value’ in something not a structure or union
cube.c:2116: error: request for member ‘action’ in something not a structure or union
cube.c:2116: error: request for member ‘key’ in something not a structure or union
cube.c:2116: error: request for member ‘keysym’ in something not a structure or union
cube.c:2116: warning: implicit declaration of function ‘XStringToKeysym’
cube.c:2116: warning: statement with no effect
cube.c:2118: error: ‘CubeDisplay’ has no member named ‘opt’
cube.c:2118: warning: statement with no effect
cube.c:2119: error: request for member ‘name’ in something not a structure or union
cube.c:2119: warning: statement with no effect
cube.c:2120: error: request for member ‘shortDesc’ in something not a structure or union
cube.c:2120: warning: statement with no effect
cube.c:2121: error: request for member ‘longDesc’ in something not a structure or union
cube.c:2121: warning: statement with no effect
cube.c:2122: error: request for member ‘type’ in something not a structure or union
cube.c:2122: warning: statement with no effect
cube.c:2123: error: request for member ‘value’ in something not a structure or union
cube.c:2123: error: request for member ‘action’ in something not a structure or union
cube.c:2123: error: request for member ‘initiate’ in something not a structure or union
cube.c:2123: error: ‘cubeNextImage’ undeclared (first use in this function)
cube.c:2123: warning: statement with no effect
cube.c:2124: error: request for member ‘value’ in something not a structure or union
cube.c:2124: error: request for member ‘action’ in something not a structure or union
cube.c:2124: error: request for member ‘terminate’ in something not a structure or union
cube.c:2124: warning: statement with no effect
cube.c:2125: error: request for member ‘value’ in something not a structure or union
cube.c:2125: error: request for member ‘action’ in something not a structure or union
cube.c:2125: error: request for member ‘bell’ in something not a structure or union
cube.c:2125: warning: statement with no effect
cube.c:2126: error: request for member ‘value’ in something not a structure or union
cube.c:2126: error: request for member ‘action’ in something not a structure or union
cube.c:2126: error: request for member ‘edgeMask’ in something not a structure or union
cube.c:2126: warning: statement with no effect
cube.c:2127: error: request for member ‘value’ in something not a structure or union
cube.c:2127: error: request for member ‘action’ in something not a structure or union
cube.c:2127: error: request for member ‘state’ in something not a structure or union
cube.c:2127: warning: statement with no effect
cube.c:2128: error: request for member ‘value’ in something not a structure or union
cube.c:2128: error: request for member ‘action’ in something not a structure or union
cube.c:2128: error: request for member ‘state’ in something not a structure or union
cube.c:2128: warning: statement with no effect
cube.c:2129: error: request for member ‘value’ in something not a structure or union
cube.c:2129: error: request for member ‘action’ in something not a structure or union
cube.c:2129: error: request for member ‘state’ in something not a structure or union
cube.c:2129: warning: statement with no effect
cube.c:2130: error: request for member ‘value’ in something not a structure or union
cube.c:2130: error: request for member ‘action’ in something not a structure or union
cube.c:2130: error: request for member ‘type’ in something not a structure or union
cube.c:2130: warning: statement with no effect
cube.c:2131: error: request for member ‘value’ in something not a structure or union
cube.c:2131: error: request for member ‘action’ in something not a structure or union
cube.c:2131: error: request for member ‘key’ in something not a structure or union
cube.c:2131: error: request for member ‘modifiers’ in something not a structure or union
cube.c:2131: warning: statement with no effect
cube.c:2132: error: request for member ‘value’ in something not a structure or union
cube.c:2132: error: request for member ‘action’ in something not a structure or union
cube.c:2132: error: request for member ‘key’ in something not a structure or union
cube.c:2132: error: request for member ‘keysym’ in something not a structure or union
cube.c:2132: warning: statement with no effect
cube.c:2134: error: ‘CubeDisplay’ has no member named ‘opt’
cube.c:2134: warning: statement with no effect
cube.c:2135: error: request for member ‘name’ in something not a structure or union
cube.c:2135: warning: statement with no effect
cube.c:2136: error: request for member ‘shortDesc’ in something not a structure or union
cube.c:2136: warning: statement with no effect
cube.c:2137: error: request for member ‘longDesc’ in something not a structure or union
cube.c:2137: warning: statement with no effect
cube.c:2138: error: request for member ‘type’ in something not a structure or union
cube.c:2138: warning: statement with no effect
cube.c:2139: error: request for member ‘value’ in something not a structure or union
cube.c:2139: error: request for member ‘action’ in something not a structure or union
cube.c:2139: error: request for member ‘initiate’ in something not a structure or union
cube.c:2139: error: ‘cubePrevImage’ undeclared (first use in this function)
cube.c:2139: warning: statement with no effect
cube.c:2140: error: request for member ‘value’ in something not a structure or union
cube.c:2140: error: request for member ‘action’ in something not a structure or union
cube.c:2140: error: request for member ‘terminate’ in something not a structure or union
cube.c:2140: warning: statement with no effect
cube.c:2141: error: request for member ‘value’ in something not a structure or union
cube.c:2141: error: request for member ‘action’ in something not a structure or union
cube.c:2141: error: request for member ‘bell’ in something not a structure or union
cube.c:2141: warning: statement with no effect
cube.c:2142: error: request for member ‘value’ in something not a structure or union
cube.c:2142: error: request for member ‘action’ in something not a structure or union
cube.c:2142: error: request for member ‘edgeMask’ in something not a structure or union
cube.c:2142: warning: statement with no effect
cube.c:2143: error: request for member ‘value’ in something not a structure or union
cube.c:2143: error: request for member ‘action’ in something not a structure or union
cube.c:2143: error: request for member ‘state’ in something not a structure or union
cube.c:2143: warning: statement with no effect
cube.c:2144: error: request for member ‘value’ in something not a structure or union
cube.c:2144: error: request for member ‘action’ in something not a structure or union
cube.c:2144: error: request for member ‘state’ in something not a structure or union
cube.c:2144: warning: statement with no effect
cube.c:2145: error: request for member ‘value’ in something not a structure or union
cube.c:2145: error: request for member ‘action’ in something not a structure or union
cube.c:2145: error: request for member ‘state’ in something not a structure or union
cube.c:2145: warning: statement with no effect
cube.c:2146: error: request for member ‘value’ in something not a structure or union
cube.c:2146: error: request for member ‘action’ in something not a structure or union
cube.c:2146: error: request for member ‘type’ in something not a structure or union
cube.c:2146: warning: statement with no effect
cube.c:2147: error: request for member ‘value’ in something not a structure or union
cube.c:2147: error: request for member ‘action’ in something not a structure or union
cube.c:2147: error: request for member ‘key’ in something not a structure or union
cube.c:2147: error: request for member ‘modifiers’ in something not a structure or union
cube.c:2147: warning: statement with no effect
cube.c:2148: error: request for member ‘value’ in something not a structure or union
cube.c:2148: error: request for member ‘action’ in something not a structure or union
cube.c:2148: error: request for member ‘key’ in something not a structure or union
cube.c:2148: error: request for member ‘keysym’ in something not a structure or union
cube.c:2148: warning: statement with no effect
cube.c: At top level:
cube.c:2151: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
cube.c:2171: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘cubeInitDisplay’
cube.c:2194: error: expected ‘)’ before ‘*’ token
cube.c:2209: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘cubeInitScreen’
cube.c:2330: error: expected ‘)’ before ‘*’ token
cube.c:2355: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘cubeInit’
cube.c:2370: error: expected ‘)’ before ‘*’ token
cube.c:2376: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘cubeDeps’
cube.c:2384: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘cubeFeatures’
cube.c:2389: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘cubeVTable’
cube.c:2413: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
make: *** [build/libcube.lo] Error 1

46. Saul Romero - noviembre 16, 2006

Ah disculpa, tal vez deba decirte que uso AMD64 y dapper, justo ahora estoy tratando de arreglar este problema igual que como le he hecho, buscando lo que me dice que falla o no hay

checking for HELIODOR… configure: error: Package requirements ( xrender >= 0.8.4 gtk+-2.0 >= 2.8.0 libwnck-1.0 beryl gconf-2.0 pangocairo libmetacity-private >= 2.15.21) were not met:

47. pancho - noviembre 16, 2006

disculpa benux 3d world funciona con intel por que no veo tutos de nada para intel
por favor escribe para saver

48. Benux - noviembre 16, 2006

respuesta a Saul Romero:
exacto vas por buen camino al buscar lo que te falta, yo no tengo un amd por o que no estoy muy familiarizado pero supongo que lo que te hace falta son repositorios, pero pues en esto si te puedo ayudar para la busqueda de los mismos.
segun veo te hacen falta algunas librerias y el elemento mas importante beryl.
aqui esta mi tuto y pues aqui esta los repositorios de beryl, tambien para amd64.
https://benux.wordpress.com/2006/10/10/como-instalar-xglberyl/
espero que te sean de ayuda, mantenme informado de tu instalación para que exista una retroalimentación de este tema ya que hace falta informacion para aquellos con amd64.

49. Benux - noviembre 16, 2006

respuesta a pancho:
pues basicamente tu intel tiene la ventaja de que es la plataforma mas facil para instalar beryl segun tengo entendido.
y pues actualize mi post de instalación de beryl para que puedan instalarlo los que tienen intel como tu.
https://benux.wordpress.com/2006/10/10/como-instalar-xglberyl/
y te recomiendo la instalacion por svn ya que es el beryl mas actual y me agrada mucho la estabilidad.
bueno y si ya tenias instalado beryl pues ya no hace falta nada, puedes seguir con la instalación de 3d world

50. Benux - noviembre 16, 2006

Respuesta a Artanix:
Estoy checando tu problema haber en que puedo ayudar, cheque las lineas de cube.c y pues parece que te faltan los valores de beryl.
lo tienes instalado?
o que distribución estas utilizando para asi buscar sobre ello.

51. Artanix - noviembre 16, 2006

sí, tengo instalado Beryl desde el svn, y funciona correctamente, eso si tuve primero problemas por dependencias incumplidas al tratar de instalar lo primero

sudo apt-get install fakeroot automake1.9 x11proto-gl-dev subversion libtool librsvg2-dev libglitz-glx1-dev libglitz1-dev libneon25-dev libapr0-dev libsvn0-dev intltool libxdamage-dev libxfixes-dev xlibs-dev icecc iceconf libxcomposite1 libxcomposite-dev libstartup-notification0-dev libwnck-dev fort77 gawk g77 build-essential cvs libpango1.0-dev libgtk2.0-dev libgconf2-dev libglitz-glx-dev librsvg2-dev checkinstall libglade2-dev

52. Artanix - noviembre 16, 2006

ah, tengo ubuntu edgy.. saludos

53. Rafa - noviembre 16, 2006

Binux sabes que podria ser que el skydome no me carge baje sky’s desde tu pagina las cambie a png y nada me aparece fondo negro. esto me pasa desde que instale edgy desde cero.

saludos

54. BERYL a la última « Alginros y sus experiencias con el software libre - noviembre 16, 2006
55. morcillaking - noviembre 17, 2006

HI benux, tremendo tuto tengo un rollo con el zoom en el cubo, el 3d world funciona todo bien pero no puedo hacer zoom in o zoom out, cuando instale el 3d world, y le daba make -f MakefileRotate
make -f MakefileZoom me decia que no habia ragumentos o faltaban ordenes no se…..

solo funciono el make, la cuestion es que no se como hacer zoom in o zoom out, habra alguna convinacion de teclas o algo..

una vez mas gracias

56. raul.martinez - noviembre 17, 2006

Hi Benux:
Segui tu guia y trate de compilar el Beryl pero despues de horas de compilar (jejeje que exageracion), me salio el error de que el paquete HELIODOR… ese que menciono Saul, alguna idea porque su post no fue contestado….

57. Rafa - noviembre 17, 2006

svn co svn://svn.beryl-project.org/beryl/branches/beryl-3d-plugin

algo pasa con el download del plugin porque solo baja dos filas 3d.c y makefile

58. Benux - noviembre 17, 2006

respuesta para morcillaking, raul y rafa:
pues en relacion al heliodor parece que falta un paquete pero el heliodor por el momento sera mejor instalarlo por repositorios aqui le dejo el link de los repositorios:
https://benux.wordpress.com/2006/11/01/tener-tu-beryl-actualizado/
y respecto al 3d world parece que no se encuentra en svn por el momento.

59. Gon - noviembre 18, 2006

Bueno, primero debo dar las gracias, acabo de instalar beryl con el 3d-world y realmente esta filete.

eso sí tuve que instalar los siguientes paquetes además de los que mencionaste:

sudo apt-get install libmetacity-dev libgnome-window-settings-dev libgnome-desktop-dev

ojala te sirva para que los agregues a la lista de tu guia.

saludos y felicitaciones

60. Benux - noviembre 18, 2006

excelente gracias a ti, y pues lo agrego en el post, mientras mas comentarios existan como este pues la guia estara mas completa y sera mas usable para todos.

61. bio - noviembre 18, 2006

ahora no baja todos los archivos de trunk,sale esto “Revisión obtenida: 1284″… baja solo 43mb en archivos, tienes algun otro link de donde bajar trunk ???

gracias

62. pancho - noviembre 19, 2006

hola amigos disculpen alguien save como puedo hacer el efecto de agua o de gotas sobre el escritorio lo vi en you tube

63. pancho - noviembre 19, 2006

por cierto escribanme si saven aleks_025@hotmail.com

64. Benux - noviembre 19, 2006

el efecto de agua es con shift+f9 y para el efecto de agua con el mouse es la tecla windows+ctrl

65. Artanix - noviembre 20, 2006

hoy llegué a la casa y había una actualización de beryl.. y venía con 3d world, asi que el problema de que no podía instalar el plugin se solucionó jaja.. saludos benux, gracias por la ayuda, larga vida a linux.

66. Benux - noviembre 20, 2006

Es cierto ya cheque, que bien ahora es mas facil para los que tenian problemas en svn.

67. locoshome - noviembre 20, 2006

Mmmm…. Ya Instalé el Ubuntu 6.10 en mi máquina, no se si me recuerdas, tengo un AMD Athlon de 64 bits y una ATI Radeon X300 SE,

Encontré un tutorial (http://fredcpp.wordpress.com/2006/09/29/instalar-beryl-en-ubuntu/) para instalar Belryl XGL en Ubuntu y lo seguí pero me salen estos errores:

……
/etc/gdm/xsession: Beginning session setup

Could not init font path element /usr/lib/X11/fonts/misc/, removing from list!
Could not init font path element /usr/lib/X11/fonts/TTF/, removing from list!
Could not init font path element /usr/lib/X11/fonts/OTF, removing from list!
Could not init font path element /usr/lib/X11/fonts/Type1, removing from list!
Could not init font path element /usr/lib/X11/fonts/CID/, removing from list!
Could not init font path element /usr/lib/X11/fonts/100Dpi/, removing from list!
Could not init font path element /usr/lib/X11/fonts/75Dpi/, removing from list!

Fatal Server Error:
could not Open Default Font ‘fixed’

(gnome-session:8425): Gtk-Warning : Cannot Open Display :

…………………

Por favor necesito ayuda!!!

68. psylosibinetic - noviembre 20, 2006

pues no se que pasa cuando pongo el comando

cd /home/roberto/beryl-3d-plugin

dice que no se encuentra, y el pluguin si esta en esa direccion soy pollo en esto que ago no podrian subir un video =

69. Benux - noviembre 20, 2006

para psylosibinetic
una pregunta el cd /home/roberto/beryl-3d-plugin lo estas haciendo desde la terminal? o desde donde?

70. Benux - noviembre 20, 2006

para locoshome:
pues no habia visto este problema, pero pues voy a buscar mas sobre el si consigo una solución te informo.

71. morcillaking - noviembre 20, 2006

hola benux, saludos cuales son las teclas a usar en el input zoom enable, para hacer lo que haces en el video. en el beryl manager salen mod1 mod2 etc pero no se cal convinacion de teclas usar…. saludos.

72. devgon - noviembre 20, 2006

tambien para los osados que instalan desde svn, puede ser conveniente usar unos repositorios donde dejan compilaciones svn-snapshot para ubuntu, el link donde se explica es este:

http://wiki.beryl-project.org/index.php/Install/Ubuntu/SVN_Snapshots_Repository

se da por supuesto que ya se tiene instalados los drivers y extensiones de X correspondientes

73. Benux - noviembre 20, 2006

para morcillaking:
para hacer el zoom in y zoom out es con la tecla de windows + la rueda del raton, y en el beryl settings, en la parte de zoom del escritorio en valores numericos colocas en maximo de zoom el valor que quieras arriba de 1,000 para que puedas hacer un zoom out, por ultimo en la pestaña de ratón asegurate que esten marcados los cuadros de Enable en cada parte.

74. hellstinger - noviembre 22, 2006

hola , que tal.. bueno tengo dos consultas.. la primera es, si existe una actualizacion mediante los repositorios oficiales de beryl,por q no quiero joderla como lo que le paso a un compañero arriba que se le puso blanco todo el cubo,tengo un amd64 con nvidia .. me funciona perfectamente beryl 0.1.1 ,pero deseo saber eso..y lo otro es saber si la version 0.1.1 soporta el efecto que siempre sale como imagen de beryl, ese donde uno ve el cubo mas pequeño,alejado y diagonal apuntando abajo, es una foto que se ve mucho, pero no he podido saber como se hace.. si se puede, por favor diganme con q teclas se hace o donde lo configuro.. gracias!
ahhh! y por si alguien le sucede el problema de que no carga beryl al inicio de sesion .. yo lo solucione haciendo esto:
sistema->preferencias->sesiones->programas de inicio->añadir y escriben “beryl-manager –force-window-manager” (sin las comillas) lo guardan, reinician sesion y deberia estar solucionado..

nada de scripts como en muchos lados lei que lo solucionaban…
a mi me funciona a la perfeccion asi (Ubuntu Edgy Eft)..

adios!🙂

75. hellstinger - noviembre 22, 2006

De ultima hora! jaja una de mis preguntas fue contestada .. la del movimiento del cubo!.. era ctrl+alt+ click derecho y se manipula el cubo las fotos las deben sacar asi.. bueno.. adios

76. x140l31 - noviembre 25, 2006

Hola, alguien sabe porqué no me funciona? :S

x140l31@s3t4m:~$ svn co svn://svn.beryl-project.org/beryl/trunk
svn: No fue posible conectarse al equipo ‘svn.beryl-project.org’

77. oalgo - noviembre 30, 2006

te funciona bien el ragnarok online?

78. Hellstinger - diciembre 2, 2006

Hola a todos.. informo que quizas algunos que deseen acualizar beryl desde los repositorios que linkean al principio de la pagina para amd64 no les resulte por problemas de dependencias de paquetes… les doy mi experiencia de que este svn sirve para ubuntu edgy en un amd64 con tarjeta nVidia, yo acabo de seguir la guia..

~$ beryl -version
beryl-core 0.1.3

y todo va perfecto con efecto 3D world icluido ..
se nota que se han corregido bugs y va mas rapido..

gracias Benux, buena guía.. y porfavor inclue que este svn sirve para amd64 tambien, ya que perdi mucho tiempo buscando la actualizacion para amd64 ..pensando q era solo para x86

79. Saul - diciembre 2, 2006

Que tal, he regresado un poco tarde por aqui pero tengo unos avances:

Para empezar quiero recordar que tengo Turion AMD64 X2, 512RAM, y una tarjeta ATI xpress 1100 (un dolor de cabeza) en un Dapper.

Nunca pude instalar la version 0.1.3 porque los repositorios que posteaste no jalan, y noté que las dependencias de Heliodor solo las cumple Edgy…, algo de libmetacity , una version que no consigo para dapper.

Decidi pasarme a la version 0.1.2 y compila todo perfecto , excepto por alguno que otro warning.

Todo corre muy bien, excepto que no tengo bordes de ventana. He revisado y me da un error de algo que no encuentra para una profundidad de 32bit (que se supone que mi tarjeta soporta). Me han dicho en canales de IRC que todo es por culpa de los drivers FLGRX, asi que lo actualicé a la version 2.17 algo asi y pues no, no funcionan los mentados bordes.

Sobra decir que estoy desesperado porque mi beryl no queda como debería, pero bueno espero que alguien me pueda ayudar con esto. GRacias

80. Saul - diciembre 2, 2006

Sorry, son los drivers 8.27.algo hehe como tengo sueño

81. anonimus - diciembre 2, 2006
82. morcillaking - diciembre 3, 2006

saludos alguno ha logrado colocar beryl en spanish… realmente no he podido…

nos vem OS

83. Benux - diciembre 3, 2006

gracias por tu comentario del amd Hellstinger, claro que actualizare el tutorial en relacion a esto.

84. Trooper - diciembre 6, 2006

Yo me tube que aventar varios tutoriales en varias paginas… afortunadamente tengo una Nvidia y wow!!! esta excelente… sin querer ahora tengo el ultimo beryl y con todo y efecto 3D world y los plugins de fuego… no no no no… otro nivel… pobre Windows vista… pobrecito…

85. Benux - diciembre 6, 2006

jajaja exacto pobre de windows, que ya no sabe que hacer, hasta sale con las jaladas de que parte del codigo de linux a sido pirateado de windows, que no mam… jajaja

86. Victor - diciembre 9, 2006

Hola de nuevo

Sabes donde puedo encontrar estos paquetes icecc iceconf fort77 checkinstall libgnome-window-settings-dev que no los encuentra synaptic a pesar que lo actualizo

Gracias

87. crescencio - diciembre 11, 2006

hola,
tengo un amd-64 y voy a comprarme una tarjeta grafica, cual me aconsejais. ati o nvidia?
gracias y saludos.

88. Benux - diciembre 11, 2006
89. Benux - diciembre 11, 2006

para crescencio:
pues veras con nvidia segun tengo entendido que va mejor con beryl por ejemplo, y son menos latosas que las ati, por otro lado las tarjetas ati son bastante potentes, y si sabes manejarlas va perfecto todo, yo tengo una ati mobility radeon x600 y no tengo ningun problema, pero pues ambas son buenas yo te aconsejo que te compres la que mas te guste.

90. crescencio - diciembre 13, 2006

hola que tal,

he mirado algunas, y esta
http://www.pc-online.net/detallesarticulos1.php?REFERENCIA=022440
me gusta bastante,
si te gusta otra en esa pagina interesante me lo comentas,
que opinas, gracias, saludos.

91. Benux - diciembre 13, 2006

pues la tuya se ve bastante bien tiene todo lo necesario para explotarla y tambien me gustaron claro esta, la serie de mi tarjeta grafica ya que me ha gustado bastate
GRAFICA PCX ATI RADEON X600PRO ABIT 256MB
y claro que tambien la que me convence es la mas cara jajaja
GRAFICA PCX ATI RADEON X1950CFE MASTER CLUB3D 512MB 650/2000 256BITS
hay busca mas si quieres, la que has escojido hasta ahorita es bastante buena.

92. crescencio - diciembre 13, 2006

tambien he mirao esta,
http://www.pc-online.net/detallesarticulos1.php?REFERENCIA=010962
que creo que esta bastante bien

opina porfa

93. Benux - diciembre 13, 2006

tambien muy buena tarjeta, y totalmente compatible con beryl, tambien vale la pena, y en cuanto al precio bastante cordial.

94. loco - diciembre 24, 2006

Que hago? instale todo conforme al tutorial, pero no pasa nada, ni siquiera puedo instalar los temas emerald, y la sesion llamada xgl no entra.
algn me podria decir que hice mal?

95. Benux - diciembre 26, 2006

seguiste los tutoriales que se mencionan al principio? en la parte que dice:

“Sigan las instrucciones del siguiente tutorial en caso de que no hayan instalado beryl anteriormente…”

96. Saul - diciembre 27, 2006

Cosa tan rara:
Ya tenia funcinando beryl, excepto por los bordes de ventana e intente volver a compilar (0.0.4) y luego (0.0.2) y me sale este horrendo mensaje

Actualizado a la revisión 2087.
autoreconf2.50: Entering directory `.’
autoreconf2.50: configure.ac: not using Gettext
autoreconf2.50: running: aclocal –output=aclocal.m4t
aclocal: macro `AM_PATH_PYTHON’ required but not defined
autoreconf2.50: aclocal failed with exit status: 1
BUILD FAILED for beryl-core

he tratado de instalar cosas que tengan que ver con python y con autoconf y nada funciona!!!

Alguiem me puede echar una mano?

97. Daniel - diciembre 30, 2006

hola, he instalado beryl con el metodo de svn, instale todo las librerias que decia al principio, depues me salte la parte donde decia “Sigan las instrucciones del siguiente tutorial en caso de que no hayan instalado beryl anteriormente” por que yo anteriormente usaba ubuntu pero la verdad gnome no me gusto e instale kubuntu, como yo ya habia instalado beryl en otro ocasion(no en kubuntu) me senti calificado para saltarme ese paso en tonces me segui con lo demas, beryl se instalo sin problemas, pero cuando quise instalar el 3d world me decia que la direccion svn… no existia asi que busque por ahi el plug in, entonces me mandaron a la sig pagina http://bugs.beryl-project.org/trac/browser/branches/beryl-3d-plugin?rev=1466 de ahi baje los dos archivos que ahi aparecen intente instalarlos con el metodo que aqui describen pero no me funciona me aparece esto:

-e compiling : 3d.c -> build/lib3d.lo3d.c: In function ‘tdPaintWindow’:
3d.c:547: error: expected statement before ‘)’ token
make: *** [build/lib3d.lo] Error 1

los archivos que que baje solo son dos:
3d.c
makefile

no se si sean todo los archivos que necesite pero son los unicos que consegui.En caso de que no sean todos alguien seria tan amable de pasarmelos o decirme de donde bajarlos se lo agradeceria mucho, espero puedan ayudarme de antemano gracias.

PD:de purar casualidad saben como puedo hacer que beryl se inicie desde el principio sin necesidad de ejecutarlo desde la consola en kde?

PD:me acabo de dar cuenta que en la barra de titulo del beryl-manager dice “0.1.5-svn” y si mal no e leido yo entiendo que apenas van en la version 0.1.3 y en la mia no trae nada del 3d world a que se debe esto? a caso lo instale mal? a parte no se ven los dibujitos de los lados de las opciones como la lamparita de “3D Effects” bueno eso es lo de menos, espero haberme explicado ( mi maquina tiene tarjeta intel y kubuntu 6.10 edgy eft)

98. angel - diciembre 31, 2006

hola creo que me sale todo bien pero a la hora de instalar esto:

svn co svn://svn.beryl-project.org/beryl/branches/beryl-3d-plugin

Me dice:

svn: El URL ‘svn://svn.beryl-project.org/beryl/branches/beryl-3d-plugin’ no existe

que puedo hacer?

99. Pablo - enero 21, 2007

hola no he instalado el 3dworld porque estoy aprendiendo y solo queria ver como funcionaba beryl ya he instalado he hecho todos los pasos de svn pero no se si tengoq eu reiniciar o que tengo que hacer luego de esto para poder ver lo efectos del beryl en mi maquina.. favor si me pueden responder a esta direccion se los agradeseria mucho. dcndnt_pablo@hotmail.com
mil gracias….

100. Carlos Méndez - febrero 6, 2007

ahorita quise actualizar el beryl pero no me sirvio… reinstalé el emerald, segui todos los procedimientos y nada… antes tenia el aiglx/beryl, que me funcionaba perfectamente, pero ahora no se que pasa que no me arranca… cuando lo arranco me sale este mensaje en el terminal

**************************************************************
* Beryl system compatiblity check *
**************************************************************

Detected xserver : AIGLX

Checking Display :0.0 …

Checking for XComposite extension : passed (v0.3)
Checking for XDamage extension : passed
Checking for RandR extension : passed
Checking for XSync extension : passed

Checking Screen 0 …

libGL warning: 3D driver claims to not support visual 0x4b
Checking for GLX_SGIX_fbconfig : passed
Checking for GLX_EXT_texture_from_pixmap : passed
Checking for non power of two texture support : passed
Checking maximum texture size : passed (2048×2048)

libberylsettings: dlopen: /usr/lib/beryl/libshowdesktop.so: undefined symbol: nWindowTypeString
libberylsettings: dlopen: /usr/lib/beryl/libresize.so: undefined symbol: pointerX
libberylsettings: dlopen: /usr/lib/beryl/librotate.so: undefined symbol: pointerX
libberylsettings: Couldn’t get vtable from ‘/usr/lib/beryl/libsettings.so’ plugin
libberylsettings: dlopen: /usr/lib/beryl/libzoom.so: undefined symbol: pointerX
libberylsettings: Couldn’t get vtable from ‘/usr/lib/beryl/libbench.so’ plugin
libberylsettings: dlopen: /usr/lib/beryl/libneg.so: undefined symbol: defaultColor
libberylsettings: dlopen: /usr/lib/beryl/libtrailfocus.so: undefined symbol: nWindowTypeString
libberylsettings: Couldn’t get vtable from ‘/usr/lib/beryl/libsplash.so’ plugin
libberylsettings: Couldn’t get vtable from ‘/usr/lib/beryl/libput.so’ plugin
libberylsettings: dlopen: /usr/lib/beryl/libmove.so: undefined symbol: pointerX
libberylsettings: dlopen: /usr/lib/beryl/libwater.so: undefined symbol: pointerX
libberylsettings: dlopen: /usr/lib/beryl/libanimation.so: undefined symbol: nWindowTypeString
libberylsettings: dlopen: /usr/lib/beryl/libwobbly.so: undefined symbol: pointerX
libberylsettings: dlopen: /usr/lib/beryl/libswitcher.so: undefined symbol: nWindowTypeString
libberylsettings: Couldn’t get vtable from ‘/usr/lib/beryl/libstate.so’ plugin
libberylsettings: Couldn’t get vtable from ‘/usr/lib/beryl/libplace.so’ plugin
libberylsettings: Couldn’t get vtable from ‘/usr/lib/beryl/libplane.so’ plugin
libberylsettings: dlopen: /usr/lib/beryl/libblurfx.so: undefined symbol: nWindowTypeString
libberylsettings: dlopen: /usr/lib/beryl/libscreenshot.so: undefined symbol: pointerX
libberylsettings: Couldn’t get vtable from ‘/usr/lib/beryl/libdecoration.so’ plugin
libberylsettings: dlopen: /usr/lib/beryl/libcube.so: undefined symbol: defaultColor
libberylsettings: Couldn’t get vtable from ‘/usr/lib/beryl/libbs.so’ plugin
libberylsettings: dlopen: /usr/lib/beryl/libscale.so: undefined symbol: nWindowTypeString
libberylsettings: Couldn’t get vtable from ‘/usr/lib/beryl/libcrashhandler.so’ plugin
libberylsettings: dlopen: /usr/lib/beryl/libfade.so: undefined symbol: nWindowTypeString
libGL warning: 3D driver claims to not support visual 0x4b
Reloading options
X connection to :0.0 broken (explicit kill or server shutdown).

Me gustaria que me ayudaran porque desde que vi el 3D world me quede obsecionado y no me voy a quedar quieto hasta que lo logre instalar, gracias… QUE VIVA UBUNTU😛

101. Carlos Méndez - febrero 6, 2007

por si acaso, mi pc es una amd athlon xp de 1.8 ghz, 1 gb de ram y una tarjeta de video asus ati radeon 9200 se, y uso ubuntu 6.10

102. Benux - febrero 7, 2007

pues no estoy muy seguro cual sea el problema pero por lo que se puede ver parece que faltan unos plugins, o tus plugins no estan bien, y pues despues de que salio el problema, despues de que intentaste instalar el 3d world o como?

103. David Ruiz - febrero 17, 2007

Como le hiciste para instalar el unreal tournament en linux amigo ????
me gustaria poder instalarlo tambien de antemano gracias por todo

104. supreme - febrero 17, 2007

psylosibinetic, eres novato en Linux y en Español verdad? Es que da una rabia leer mensajes tan MAL escritos..

105. supreme - febrero 17, 2007

..eres de mexico verdad?

106. mitonline - febrero 18, 2007

You need Subversion package installed
to use this feature ese error me aparece cuando quiere ejecutar el Emerald theme manager}
me puede ayudar

mito gracias

107. vacadepollo - febrero 18, 2007

En este vídeo http://www.adslzone.tv/especial-ubuntu-linux/ e visto un efecto que no soy capaz de encontrar. ES, que al pasar el ratón por encima de la ventana hace como un efecto de bandera, una onda muy chula, sabeis donde?

E mirado en efectos visuales-tambalear ventanas y nada….

108. Oscar Martinez - febrero 26, 2007

que tal soy un poco nuevo en esto de linux… y poco a poco voy entendiedole , resulta que estaba iniciando como lo menciona el tutorial para instalar beryl desde svn pero al hacer el primer paso que es:

sudo apt-get install fakeroot automake1.9 x11proto-gl-dev subversion libtool librsvg2-dev libglitz-glx1-dev libglitz1-dev libneon25-dev libapr0-dev libsvn0-dev intltool libxdamage-dev libxfixes-dev xlibs-dev icecc iceconf libxcomposite1 libxcomposite-dev libstartup-notification0-dev libwnck-dev fort77 gawk g77 build-essential cvs libpango1.0-dev libgtk2.0-dev libgconf2-dev libglitz-glx-dev librsvg2-dev checkinstall libglade2-dev libmetacity-dev libgnome-window-settings-dev libgnome-desktop-d

Me sale el siguiente error en la consola, podrian orientarme para ver que me falta (la version de linux es ubuntu dapper):

El paquete libglitz-glx-dev es un paquete virtual provisto por:
libglitz-glx1-dev 0.5.6-0ubuntu1
Necesita seleccionar explícitamente uno para instalar.
E: El paquete libglitz-glx-dev no tiene candidato para su instalación

Gracias espro me puedan ayudar….

109. Diurno - marzo 7, 2007

Cuando pongo svn co svn://svn.beryl-project.org/beryl/branches/beryl-3d-plugin
me dice: doesn’t exist

Que hago?!
ya hice todo lo de arriba

110. Benux - marzo 10, 2007

para vacadepollo:
ese efecto si lo estas activando de maner correcta, el unico problema es que no con todos funcionan bien los efectos, es la bronca de que el cubo este todavia en etapa alpha, porque no creo que ya esten en la beta, lo que queda es esperar actualizaciones y seguir probando.

para oscar:
pues lo que te esta diciendo es que un paquete ya contiene el otro, asi que solo borra libglitz-glx-dev de todos los archivos que se van a instalar y deja el libglitz-glx1-dev.

para diurno:
me he desconectado un poco de la parte svn y he dejado que me actualice todo el cubo desde repositorios, ya que el 3d-world ya se encuentra dentro de ellos, y bueno respecto a tu error, lo mas probable esque ese link ya no exista, o tenga otra direccion seria cuestion de checar, pero lo que recomiendo ahorita es que todos usemos los repositorios de tuxfamily, aqui dejo el link para que entres https://benux.wordpress.com/2006/11/01/tener-tu-beryl-actualizado/

111. gNdx - marzo 14, 2007

estubo nice =) la intalacion i todo
peroo, no m muetra el gestor de ajustes del beryl q puedo hcr?

112. Joze - marzo 24, 2007

Hey … nadie ha tenido problemas al compilar Beryl, con el fichero wall.c????

113. Mtrx - abril 7, 2007

hoLa tenGo un pRobleMa me saLE el sigiente erroR

wall.c:51:20: error: GL/glu.h: No such file or directory
wall.c: In function ‘invertTransformedVertex’:
wall.c:1302: warning: implicit declaration of function ‘gluUnProject’
wall.c:1302: warning: nested extern declaration of ‘gluUnProject’
make[3]: *** [wall.lo] Error 1
make[3]: se sale del directorio `/home/mtrx/trunk/beryl-plugins/src’
make[2]: *** [all-recursive] Error 1
make[2]: se sale del directorio `/home/mtrx/trunk/beryl-plugins/src’
make[1]: *** [all-recursive] Error 1
make[1]: se sale del directorio `/home/mtrx/trunk/beryl-plugins’
make: *** [all] Error 2
BUILD FAILED for beryl-plugins

me podrian ayudar

grax

Salu2..

114. Mtrx - abril 7, 2007

hoLa ia no saLe eze eRror xD
ahora sale zte
make: *** No se especificó ningún objetivo y no se encontró ningún makefile. Alto.
BUILD FAILED for aquamarine

ayuDeme plz

grax

Salu..

115. Como Instalar XGL/BERYL en Gnome/Kde intel, Nvidia y ATI Dapper/Edgy | Benux Advent - abril 8, 2007

[…] BERYL ACTUALIZADO DESDE SVN […]

116. jaime - abril 9, 2007

Hola buenas a todos.
Estoy intentando actualizar mi beryl en dapper como se explica en este blog, que está genial.
tengo un problema durante la intalación ya que cuando hago el ./makeall en un momento me da este error :


checking for GLIB… yes
checking for BCOP… checking for ANNOTATE… checking for TEXT… checking for DBUS… configure: error: Package requirements (dbus-1) were not met:

No package ‘dbus-1’ found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables DBUS_CFLAGS
and DBUS_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

BUILD FAILED for beryl-plugins

y es que no soy capaz de encontrar ese paquete por ningun lado
tengo instalado el dbus pero no el dbus-1
y ni actualizando los repos ni nada
estaría muy agradecido si me hechaseis una manilla, muchas gracias

117. Supirole - mayo 7, 2007

Pues yo tengo un par de problemas a la hora de instalarlo.

1º No puedo instalar :

libgnome-window-settings-dev
libglitz-glx-dev

2º Al intentar compilarlo, me indica un error :

missing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -MT wall.lo -MD -MP -MF .deps/wall.Tpo -c wall.c -fPIC -DPIC -o .libs/wall.o
wall.c:51:20: error: GL/glu.h: No such file or directory
wall.c: In function ‘invertTransformedVertex’:
wall.c:1302: warning: implicit declaration of function ‘gluUnProject’
wall.c:1302: warning: nested extern declaration of ‘gluUnProject’
make[3]: *** [wall.lo] Error 1
make[3]: Leaving directory `/home/supirole/trunk/beryl-plugins/src’
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/supirole/trunk/beryl-plugins/src’
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/supirole/trunk/beryl-plugins’
make: *** [all] Error 2
BUILD FAILED for beryl-plugins

Si alguien tiene idea de cual sea mi problema, por favor ayudeme.

(Ubuntu 6.06, actualmente tengo beryl .1.1 funcionando, pero antes de compilar lo quito y reincio para que no halla problema. y estoy trabajando con XGL en una NVidia geforce fx5200)


Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: